Ticket #10219 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Full Source Edit appears to be broken

Reported by: Katherine Fletcher <kef@…> Owned by: schatz
Priority: critical Milestone: BugFix - 2010
Component: Unknown Version: Live
Severity: severe Keywords: ReportABug
Cc: System Area: Authoring
Primary Skill: Unspecified
Site URL: http://cnx.org/GroupWorkspaces/wg474/m13240/module_text?portal_status_message=Saved.&edit_source:int=1
Suppress email to reporter: no

Description (last modified by schatz) (diff)

I checked out m13240 into my personal workspace (originally to test reuse/edit) and it auto upgraded to 0.7 and then I added "Hello. I am editing my module. " to the very first paragraph.

Then I got the following error:

Please correct the following errors: Line 85: fatal: The element type "m:mrow" must be terminated by the matching end-tag "</m:mrow>".

Note: Edit-In-Place cannot be used while errors persist

Attachments

m10000.zip (18.7 KB) - added by kef 7 years ago.
Math module that can't be saved in full source in chrome without goofing things up.

Change History

  Changed 7 years ago by schatz

  • owner changed from ew2 to schatz
  • status changed from new to working
  • suppressreporteremail unset
  • description modified (diff)

follow-up: ↓ 3   Changed 7 years ago by schatz

I could reproduce the bug in Chrome (5.0.335) but not in Firefox 3.5 . It is still odd that validation fails but the cnxml is saved.

in reply to: ↑ 2 ; follow-up: ↓ 4   Changed 7 years ago by kef

Full source allows you to save things with errors.

Replying to schatz:

I could reproduce the bug in Chrome (5.0.335) but not in Firefox 3.5 . It is still odd that validation fails but the cnxml is saved.

in reply to: ↑ 3 ; follow-up: ↓ 5   Changed 7 years ago by reedstrm

Replying to kef:

Full source allows you to save things with errors. Replying to schatz:

I could reproduce the bug in Chrome (5.0.335) but not in Firefox 3.5 . It is still odd that validation fails but the cnxml is saved.

Yup, it's an interaction between Chrome and the textarea wrap attribute. We send wrap='on' The spec says wrap takes values of 'hard', 'soft', 'off'. Turns out 'soft' is the default. We could probably remove the attribute completely. That'll need some cross-browser testing, I suppose. (RhaptosModuleEditor?, the module_text.cpt skin, as well as module_publish.cpt and module_metadata.cpt and module_send_patch.cpt)

in reply to: ↑ 4   Changed 7 years ago by reedstrm

Replying to reedstrm:

Replying to kef:

Full source allows you to save things with errors. Replying to schatz:

I could reproduce the bug in Chrome (5.0.335) but not in Firefox 3.5 . It is still odd that validation fails but the cnxml is saved.

Yup, it's an interaction between Chrome and the textarea wrap attribute. We send wrap='on' The spec says wrap takes values of 'hard', 'soft', 'off'. Turns out 'soft' is the default. We could probably remove the attribute completely. That'll need some cross-browser testing, I suppose. (RhaptosModuleEditor?, the module_text.cpt skin, as well as module_publish.cpt and module_metadata.cpt and module_send_patch.cpt)

I should say, the _old_ spec says: HTML4 (and XHTML) have no such attribute, you're supposed to use CSS whitespace: control. I recommend we remove the attribute.

  Changed 7 years ago by schatz

  • status changed from working to testing

(In [32951]) Changed textarea/@wrap to "soft" instead of "on" for WebKit? support. Fixes #10219

  Changed 7 years ago by schatz

(In [32958]) Removed textarea/@wrap='soft' since WebKit? and Firefox default to it. Fixes #10219

  Changed 7 years ago by ew2

  • milestone changed from Ticket Triage to Hot Fixes

  Changed 7 years ago by bnwest

  • status changed from testing to closed
  • resolution set to fixed

FSE works and as well as the other textareas that were fixed.

  Changed 7 years ago by kef

This does not seem to have been rolled out. Full Source Edit is still broken for Chrome. Edit in Place and math viewing are not supported for non Firefox/IE, but everything else is so we should try and get this rolled out.

  Changed 7 years ago by ew2

  • status changed from closed to accepted
  • resolution fixed deleted

  Changed 7 years ago by kef

Here is a module that is causing the problem -- http://cnx.org/GroupWorkspaces/wg1564/module.2010-06-07.4186402788/module_text

You can get into that state by importing using the attached zip and then using chrom to edit in full source and saving.

Changed 7 years ago by kef

Math module that can't be saved in full source in chrome without goofing things up.

  Changed 6 years ago by ew2

  • priority changed from unprioritized to critical
  • milestone changed from Hot Fixes to BugFix - 2010

  Changed 6 years ago by schatz

  • status changed from accepted to testing

(In [35308]) Should work in safari and IE. Fixes #10219

  Changed 6 years ago by kef

Will it still be broken for Chrome? If so, it must be disabled for Chrome so that it is not trivial to completely hose your module and lose lots of work.

To make clear how the work is lost.

Step 1: Do lots of really cool editing in Firefox using EIP or whatever. Step 2: See a little typo and make a change in the full source editor in Chrome. Step 3: The entire module is hosed.

  Changed 6 years ago by schatz

Sorry about the confusion. I tried it in Webkit browsers (Safari/Chrome) and IE and it appears to work in both.

  Changed 6 years ago by maxwell

  • status changed from testing to closed
  • resolution set to fixed

I tried the originally reported module and the attached one. Neither presented, in Chrome, the problem I saw when trying to edit them on production (which for me, was an error reading fatal: Attribute name "target-" associated with an element type "link" must be followed by the ' = ' character."). I also tried them in the Rhaptos skin in IE and Safari, and didn't see problems there either. Calling this fixed.

  Changed 6 years ago by maxwell

  • status changed from closed to accepted
  • resolution fixed deleted

Fix needs to be put on branch and retested.

  Changed 6 years ago by schatz

  • status changed from accepted to working

This appears to be on the branch.

  Changed 6 years ago by schatz

  • status changed from working to testing

  Changed 6 years ago by ew2

  • status changed from testing to closed
  • resolution set to fixed

imported attached module into Wakizashi. Tested full source edit in Chrome, Firefox and IE 7. All worked, so this is fixed.

Note: See TracTickets for help on using tickets.