Ticket #10914 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

eDGe not correctly displaying some MathML, consider embedding fonts

Reported by: maxwell Owned by: schatz
Priority: critical Milestone: BugFix - 2010
Component: Other Imports/Exports Version: Live
Severity: severe Keywords:
Cc: schatz System Area: Content Display
Primary Skill: Several Equally
Site URL:
Suppress email to reporter: no

Description

From an e-mail from Entourage:

"Some math symbols are being displayed as question marks.  The math causing the problem is correctly encoded, but without the correct fonts, it will not display. You can see the problem in this EPUB: http://cnx.org/content/col10232/1.1/epub.  If you look at the second chapter [Max: actually "Chapter 1"], you can see three question marks in a row (?,?,?).  There are others inside equations."

Adobe responded:

"This file uses very specialized characters (ℚ, ℝ, ℂ) and yet it does not embed a font for them. Our fonts do not have these symbols. Font must be embedded in this case. I did not find an easy method to subset and embed the glyphs that they need, so they either have to embed the complete font or subset it by hand. The font still must be embedded, though. Math characters are not going to be available on all platforms."

Here is a page about how to embed fonts in EPUBs:

http://blog.threepress.org/2009/09/16/how-to-embed-fonts-in-epub-files/

Since it presumably would make all the EPUBs larger, we might want to consider 1) only doing this for EPUBs with MathML, or 2) figuring out what class of characters are not displaying correctly and using images for these instead of the simple math method.

Attachments

offline-text-small.png (27.2 KB) - added by maxwell 6 years ago.
New text is oddly thin, unreadable.
ozip-font-size-1em.png (6.7 KB) - added by maxwell 6 years ago.

Change History

Changed 6 years ago by schatz

  • status changed from new to testing

(In [35224]) Rhaptos versions of epubs should now render differently and STIX math fonts should now be embedded in module and collection epubs. Fixes #10657 and #10914

Changed 6 years ago by ew2

  • milestone changed from Ticket Triage to BugFix - 2010

Changed 6 years ago by maxwell

New text is oddly thin, unreadable.

Changed 6 years ago by maxwell

  • status changed from testing to assigned

Those missing characters are now displaying in the eDGe, but the new fonts, which are being applied to the entire document, make the fonts appear significantly smaller and, in some OSs, thinner, in the Offline ZIPs (I'm not sure why there doesn't seem to be a difference in the EPUB on iPad). The O-ZIP text was already very small, but now it's nearly unreadable in Windows (see attachment). I recommend bumping up the font-size property on body to probably .85em.

Changed 6 years ago by ew2

  • owner changed from ew2 to schatz

Changed 6 years ago by schatz

  • status changed from assigned to testing

(In [35435]) Increases body font size by 33% (from .75em to 1em). Fixes #10914

Changed 6 years ago by maxwell

Changed 6 years ago by maxwell

The Offline ZIP text is now easier to read across all browsers, though is still oddly thin in Windows browsers (see new screenshot). In the iPad, the EPUB text is quite a bit larger, along the lines of the text in the "Winnie the Pooh" EPUB, which could make us look as if we were putting out "large print edition" or books for younger students or whatever, but I suppose the text is adjustable in the iPad. My bigger concern would be that it would start out very large for smaller devices and that things would wrap every 3 words. In the eDGe, I thought the size of the EPUB text looked fine.

Changed 6 years ago by ew2

  • status changed from testing to assigned

Sending this back so Max can add a CSS file for the Offline zip. Then, Philip can add it to the offline zip build.

Changed 6 years ago by ew2

  • owner changed from schatz to maxwell

Changed 6 years ago by maxwell

(In [35455]) Add small CSS file just for inclusion in Offline ZIPs. Since I believe the font problem was restricted to the eDGe, I decided to make the Offline ZIP default to a sans-serif typeface, but that can be changed if it's problematic. Refs #10914. This also refs #10685.

Changed 6 years ago by maxwell

  • owner changed from maxwell to schatz

This should be ready for inclusion. Be sure that it goes after content.css in the mark-up, not before.

Changed 6 years ago by ew2

  • priority changed from unprioritized to critical
  • severity changed from minor to severe

Changed 6 years ago by schatz

  • status changed from assigned to testing

(In [35482]) Offline zip now uses a different CSS that extends the epub one. Fixes #10685 and #10914

Changed 6 years ago by schatz

(In [35483]) Offline zip now uses a different CSS that extends the epub one. Fixes #10685 and #10914

Changed 6 years ago by ew2

  • status changed from testing to closed
  • resolution set to fixed

The math is displaying correctly on the Edge and the Nook. This is fixed.

Note: See TracTickets for help on using tickets.