Ticket #4266 (closed enhancement: fixed)

Opened 9 years ago

Last modified 8 years ago

render online display for bibTeXML references as "[1]" like the print system

Reported by: rwagner Owned by: maxwell
Priority: medium Milestone: Module Edit Workflow - MyCNX Dashboard
Component: Content Viewing Version: Live
Severity: major Keywords: Sprint 2, Story 15, related-bug-fix, emptycnxn
Cc: bnwest, dcwill System Area: Content Display
Primary Skill: XML/XSLT
Site URL: http://cnx.org/content/m18243/1.2/
Suppress email to reporter: no

Description (last modified by kef) (diff)

singleton <cnxn/>'s to BibTeXML items render correctly as the citation number of the item, but rather than just the number, it would be more in line with standard citation conventions for them to wrap square brackets around the citation number. that is, to render as [1] where "1" in this case is an example of the citation number.

As an example with some BibTeXML and <cnxn/> tags pointing to those items, .zip import the attached .zip file.

See Scott's explanation and screen shots below. The online system should definitely display them the way that the print system does.

Attachments

specanal-bnw.zip (285.0 KB) - added by rwagner 9 years ago.
4266_online_scrn.png (45.1 KB) - added by sk8 9 years ago.
4266_print_scrn.png (86.2 KB) - added by sk8 9 years ago.

Change History

Changed 9 years ago by rwagner

Changed 9 years ago by kef

  • milestone changed from future to LaTeX importer ready for Production Testing

Changed 9 years ago by maxwell

  • skills changed from Unspecified to XML/XSLT
  • type changed from enhancement to defect
  • area changed from Unknown to Content Display

This is related to #4211 in that it's appearing to just want to output the number, but that's only because our i18n xml/xslt stuff doesn't have a translation/mapping for bib:entry. When I throw <l:gentext key="entry" text="Entry"/> into cnxmll10n.xsl, the module suddenly shows these cnxns outputting as "Entry 1", "Entry 2", etc. If we're going to change these kinds of cnxns to be bracketed numbers, though, it should just require putting in a special case in the cnxn template in unibrowser.xsl, instead of worrying about the translation/mapping stuff.

Changed 9 years ago by bnwest

  • type changed from defect to enhancement

Changed 9 years ago by kef

  • cc bnwest added

I am putting this in Future for now since it did not seem to be addressed in the LaTeX rollout. It can go into Near Future if it is a bug that needs to get fixed, but it seems to be languishing right now.

Changed 9 years ago by kef

  • milestone changed from LaTeX importer ready for Production Testing to future

Changed 9 years ago by maxwell

  • cc dcwill added
  • status changed from new to assigned

Closing #6685 as essentially a duplicate of this ticket (though I'll note that #6685 was written at a time when the link was indeed changed to output "Entry 1", "Entry 2", etc.).

CNXML 0.6 would probably be a good time to address this.

Changed 9 years ago by maxwell

  • milestone changed from future to CNXML 0.6

I forgot to change the milestone.

Changed 9 years ago by maxwell

Also closing #6533 as a duplicate.

Changed 9 years ago by ew2

  • owner changed from maxwell to sk8

Please look into and add screenshot of problem

Changed 9 years ago by sk8

As the attached screenshots show, the online system replaces an empty bibTeXML cnxn with Entry 1, while the print system replaces it with [1]. Note that although the numbering is different, both reference systems are correct (the online system just doesn't order alphabetically, although it sure is close; see #6990).

Changed 9 years ago by sk8

Changed 9 years ago by sk8

Changed 9 years ago by kef

  • description modified (diff)
  • summary changed from online display for bibTeXML references to render online display for bibTeXML references as "[1]" like the print system
  • priority changed from low to medium
  • owner changed from sk8 to maxwell
  • keywords related-bug-fix added
  • severity changed from minor to major

Changed 9 years ago by kef

  • contentobj modified (diff)

Changed 9 years ago by ew2

  • milestone changed from CNXML 0.6 to AuthIntRedesign- Landing Page And Navigation

Changed 9 years ago by maxwell

  • milestone changed from AuthIntRedesign- Landing Page And Navigation to CNXML 0.6 - Phase 2

This should be in CNXML 0.6 Phase 2 w/ the other tickets related to empty cnxn text generation.

Changed 9 years ago by ew2

  • milestone changed from CNXML 0.6 - Phase 2 to AuthIntRedesign- Landing Page And Navigation

We plan on fixing this one in the Module Edit Workflow - Author Home and Left Navigation Milestone which is why I moved it there. It is on the Sprint backlog.

Changed 8 years ago by maxwell

  • keywords related-bug-fix, emptycnxn added; related-bug-fix removed
  • suppressreporteremail set

Changed 8 years ago by maxwell

  • keywords Sprint 2, Story 15, added

Changed 8 years ago by maxwell

  • status changed from assigned to testing

(In [26541]) Instead of outputting empty <cnxn>/<link>s to bibtex entries as "Entry 1", output them as "[1]". Also, use name() instead of local-name() to generate numbers so as not to confuse bib:entry with cnx:entry (in tables). Fixes #4266.

Changed 8 years ago by natalie

  • status changed from testing to closed
  • resolution set to fixed

The notation here has been corrected, although the online ordering is still different (addressed in #6990).

Changed 8 years ago by natalie

  • suppressreporteremail unset

Whoops, email was suppressed to reporter. Ding ding.

Note: See TracTickets for help on using tickets.