Ticket #8542 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

EIP edit box does not display ID of tables as it does for other elements

Reported by: je2 Owned by: bnwest
Priority: unprioritized Milestone: Hot Fixes
Component: Edit-in-Place Version:
Severity: minor Keywords:
Cc: manpreet, ew2 System Area: Authoring
Primary Skill: Unspecified
Site URL:
Suppress email to reporter: no

Description

Noticed this when trying to show a user how to create dynamic links to tables . . . in most elements, such as <para>, the EIP edit window displays (in fixed, white text as part of the opening tag) the element's ID. This makes it easy to identify in order to set up links, etc. However, the <table> element does not display the ID, requiring the user to go into full-source mode (or a parent tag's editor) to find the relevant ID. This is problematic, especially for relatively new users not comfortable with full source mode, and discourages the use of dynamic references.

We need to tweak the interface so that element IDs display for tables, and confirm that this is not a problem for other elements as well.

Putting in "Hot Fixes" for lack of a relevant short-term milestone, but feel free to reassign as appropriate.

Change History

follow-up: ↓ 2   Changed 8 years ago by je2

One more thing - I actually can't recall if this is a regression or an existing problem, as previously I was instructing authors to reference the <figure> element that was (more often than not) encapsulating the table. The fact that we are no longer wrapping tables in figures makes this a much more relevant issue than it would have been previously, in any case.

in reply to: ↑ 1   Changed 8 years ago by bnwest

Replying to je2:

The fact that we are no longer wrapping tables in figures makes this a much more relevant issue than it would have been previously, in any case.

Not factual ;)

Tables can be wrapped by a figure in CNXML 0.6. IIRC this was a late change to the schema.

  Changed 8 years ago by je2

Ah, you see, this is why I shouldn't leave for weeks at a time. You miss things like this.

In any case, the Word importer will import tables without using a figure tag, which is what happened with this user.

  Changed 8 years ago by bnwest

  • cc manpreet added; ew2, je2, maxwell removed
  • status changed from new to working

We do not expose the <table ...> tag (or </table>) in EIP edit UI, like we do for <para> et. al. To include the table id would require a UI change.

IIRC, we previously decided not include the <table ...> tag, to decrease the table edit UI footprint and to make the table edit UI less busy.

CCing Manpreet for her input.

  Changed 8 years ago by bnwest

  • cc ew2 added
  • status changed from working to awaitinginput

We might consider adding a read-only field to the EIP table edit UI which displays the table @id.

We need Manpreet's input before we can go forward.

  Changed 8 years ago by manpreet

  • status changed from awaitinginput to assigned

I think it should be OK to add the table id in the UI in fixed text as we do for paras and other elements. It will make the interface a bit busier but seems needed. Brian - Can I see it once it is implemented? Or do we need Max to mock this up?

  Changed 8 years ago by bnwest

  • status changed from assigned to testing

(In [26913]) display the table tag as part of the EIP table edit UI.

fixes ticket:8542.

  Changed 8 years ago by je2

  • status changed from testing to assigned

The </tgroup> tag is displayed in the right place, but the </table> tag should really be displayed after the caption and table summary blocks (see the editor for the <figure> element as an example). Conferred with Manpreet and she agreed that this should be moved down.

  Changed 8 years ago by bnwest

  • status changed from assigned to testing

<code> has caption edit widgit below its closing tab label.

Sending back to testing. If the consistency of the placement of the closing label wrt the caption edit widgit is bothersome, open another ticket.

  Changed 8 years ago by je2

Will open a new ticket for consistency of <code>, <figure>, and <table> edit windows. The ID is displaying now, so that piece is good to go.

I'm signing off on this fix for my part.

  Changed 8 years ago by ew2

  • status changed from testing to closed
  • resolution set to fixed

Released on 3-19-2009

Note: See TracTickets for help on using tickets.