Ticket #9447 (closed defect: fixed)

Opened 8 years ago

Last modified 7 years ago

Workgroup forums not showing up for Siyavula users

Reported by: kef Owned by: jccooper
Priority: high Milestone: Hot Fixes
Component: Workgroups/Workspaces Version: Live
Severity: major Keywords:
Cc: System Area: Unknown
Primary Skill: Plone
Site URL:
Suppress email to reporter: no

Description

It looks like when ticket:8654 was fixed (forums being available for non-siyavula users) it was fixed too well and now it is not available for siyavula users.

The forums should show up for any workgroup that has a member that is also a member of the siyavula 'special' workgroup, which is wg1438.

The code actually checks for pg.getGroupsForPrincipal(auth_member)[0] which is currently wg1438. If this can change when new workgroups are added, then we have a problem.

Change History

  Changed 8 years ago by jccooper

  • status changed from new to working

By experiment, it seems stable and ordered:

>>> pg.getGroupsForPrincipal(siyavula_member)
('wg1438', 'wg1475', 'wg1476', 'wg928')

I really can't say it's a solid algorithm, but it's not obviously a problem for normal usage.

follow-up: ↓ 4   Changed 8 years ago by jccooper

  • status changed from working to testing

(In [29202]) fix #9447: add forum links to certain workgroups, since prior algorithm based on #8654 disabled them on all workgroups. Now, any workgroup that has as a member any of the members of the siyavula workgroup (the first WG in the siyavula list, currently wg1438) will have forums. Lenses owned by siyavula should also continue to have the forum link. Nothing else should.

  Changed 8 years ago by jenn

  • summary changed from Workgroups not showing up for Siyavula users to Workgroup forums not showing up for Siyavula users

in reply to: ↑ 2   Changed 8 years ago by jenn

  • skills changed from Unspecified to Plone
  • status changed from testing to assigned
  • version set to Live

Replying to jccooper:

Now, any workgroup that has as a member any of the members of the siyavula workgroup (the first WG in the siyavula list, currently wg1438) will have forums.

So, if I add the "drummond" user to wg1438, then that user should see a forum link on all its other workgroups? I'm not seeing that; when logged in as drummond, I still only see a forum link on the main siyavula workgroup. Have reconfirmed that I'm running trunk for the Siyavula product.

  Changed 8 years ago by jccooper

Some older workgroups appear to not be owned properly by their groups, but rather a manager. In this case the check fails. I know at least one 'risa*' is like that. I'm looking into ways of working around.

  Changed 8 years ago by kef

I don't think we care about older workgroups for this at all do we????

  Changed 8 years ago by jenn

That's a pretty major bug to leave lying around, but I suppose if we're just desperately trying to get it working for tomorrow, we could punt.

  Changed 8 years ago by jccooper

  • status changed from assigned to testing

(In [29223]) Older WGs (risaXXX) seem to be owned not by their groups but by the migrating owner from way back when ('jccman'). So, make the check a little more specific to WGs in order to cover this case. No big loss; this isn't really general case code anyway. Fix #9447

  Changed 8 years ago by jccooper

(In [29231]) add comments wrt 'view' and desired behavior of forum link test. no code change. see #9447

  Changed 8 years ago by jenn

  • status changed from testing to closed
  • resolution set to fixed

Rolled out 8/20.

Note: See TracTickets for help on using tickets.