Ticket #9934 (closed defect: fixed)

Opened 8 years ago

Last modified 6 years ago

some metadata don't survive derivation

Reported by: maxwell Owned by: schatz
Priority: critical Milestone: BugFix - 2010
Component: Authoring Environment Version: Live
Severity: severe Keywords:
Cc: System Area: Authoring
Primary Skill: Unspecified
Site URL:
Suppress email to reporter: no

Description

I tried deriving a copy of a module that I had set to Spanish language and with all 6 subjects checked. I published it, then derived a copy, and the language had been reset to English and only the "Arts" subject was checked. Keywords and summary survived the derivation, and I didn't check Google Analytics code (I assume that was tested specifically when that was rolled out). I also didn't test collections.

Change History

  Changed 8 years ago by ew2

  • owner changed from jccooper to ew2
  • status changed from new to assigned

  Changed 7 years ago by maxwell

The cause of #10009 is probably related to this ticket

  Changed 7 years ago by ew2

  • owner changed from ew2 to schatz
  • priority changed from unprioritized to critical
  • severity changed from minor to severe
  • milestone changed from Ticket Triage to BugFix - 2010

follow-up: ↓ 5   Changed 7 years ago by schatz

Using an empty cnx instance the bug is reproduced by some in FF and Chrome but not by me.

in reply to: ↑ 4   Changed 7 years ago by schatz

Replying to schatz:

Using an empty cnx instance the bug is reproduced by some in FF and Chrome but not by me.

oops, wrong ticket

  Changed 7 years ago by schatz

For me all the subjects, keywords, roles, and abstract in the derived copy are preserved but the language is not.

  Changed 7 years ago by schatz

  • status changed from assigned to testing

(In [35307]) Language does not reset to english (default) when a derived copy is made. Fixes #9934

  Changed 7 years ago by maxwell

  • status changed from testing to closed
  • resolution set to fixed

Checked collections and metadata. All metadata (except GA code, as desired) and also links and parameters copy correctly into the derived copy, whether or not that metadata was done before publication, or to a checked out copy right before derivation. Roles are a separate issue.

  Changed 7 years ago by maxwell

  • status changed from closed to accepted
  • resolution fixed deleted

Fix needs to be put on branch and retested.

  Changed 7 years ago by schatz

  • status changed from accepted to working

It appears this fix is in the branched code.

  Changed 7 years ago by schatz

  • status changed from working to testing

  Changed 7 years ago by maxwell

This was tested on 11/17, but the branch wasn't created till 11/18, so I'll need to test again. :-(

  Changed 7 years ago by maxwell

  • status changed from testing to assigned

I set a collection to have language "it-si" and when I derived it (as another author, not that that should matter), it changed the language to "en". All other metadata and parameters were retained (or not) as desired. Tested with col10006 on bread:9191.

  Changed 7 years ago by schatz

  • status changed from assigned to awaitinginput

It seems this was fixed for modules but not collections. I spent a few hours hunting this down and it appears Products.RhaptosModuleEditor/Products/RhaptosModuleEditor/skins/rhaptos_module_editor/forkContent.cpy

is called for collections as well as modules and in it context refers to the original collection/module (since context.Title() is used to set the title of the new module/collection but context.Language() returns "" and context.language yields "en". So, taking a break for now.

  Changed 7 years ago by ew2

  • status changed from awaitinginput to assigned
  • milestone changed from BugFix - 2010 to Ticket Triage

This will not make it into the Bug Fix release. Moving back to Triage.

  Changed 7 years ago by maxwell

  • milestone changed from Ticket Triage to BugFix - 2010

Code has been committed for this ticket, so before removing from milestone, we need to evaluate whether or not we undo that code.

  Changed 7 years ago by schatz

  • status changed from assigned to testing

Moving back into test so it gets tested

  Changed 6 years ago by ew2

  • status changed from testing to assigned

Needs to be fixed for collections before testing.

  Changed 6 years ago by schatz

  • status changed from assigned to awaitinginput

Should we split these into two tickets or change the scope to just modules (which is fixed)?

  Changed 6 years ago by kef

  • status changed from awaitinginput to assigned

Split the tickets.

  Changed 6 years ago by reedstrm

I don't see a ticket this has split too? As it happens, collections are more broken than that: checkout loses the language as well (live)

  Changed 6 years ago by reedstrm

  • status changed from assigned to testing

(In [35544]) make sure language is copied properly when checking out (or deriving a copy). Fixes #9934 (this time, for sure!)

  Changed 6 years ago by ew2

  • status changed from testing to closed
  • resolution set to fixed

Derived spanish collection and modules. The language continued to be Espanol. This is fixed.

Note: See TracTickets for help on using tickets.